re = /^\d+(?:\.[a-zA-Z]?\d+)*$/m
str = '123.123.123.132
123123213123
123.a123.b123.123
123.aa1.bb12
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end