// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d+(?:\.[a-zA-Z]?\d+)*$").unwrap();
let string = "123.123.123.132
123123213123
123.a123.b123.123
123.aa1.bb12
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}