using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9]{4}-[0-9]{2}-[0-9]{2})";
string input = @"Bonjour j'ai donc une chaine qui est du texte avec une date a l'interrieur par exemple: 2017-05-12 , comment recuperer cette date";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}