// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([0-9]{4}-[0-9]{2}-[0-9]{2})").unwrap();
let string = "Bonjour j'ai donc une chaine qui est du texte avec une date a l'interrieur par exemple: 2017-05-12 , comment recuperer cette date";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}