re = /([0-9]{4}-[0-9]{2}-[0-9]{2})/
str = 'Bonjour j\'ai donc une chaine qui est du texte avec une date a l\'interrieur par exemple: 2017-05-12 , comment recuperer cette date'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end