package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([0-9]{4}-[0-9]{2}-[0-9]{2})`)
var str = `Bonjour j'ai donc une chaine qui est du texte avec une date a l'interrieur par exemple: 2017-05-12 , comment recuperer cette date`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}