# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:[\d]{2,3}?(?::IF))?[\s,&]+(?:with)?|(\S+)//gm;t' <<< "01:IF rd.h && dq.L && o.LL && v.L THEN la.VHB , av.VHR with 0.4610;"