package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[\d]{2,3}?(?::IF))?[\s,&]+(?:with)?|(\S+)`)
var str = `01:IF rd.h && dq.L && o.LL && v.L THEN la.VHB , av.VHR with 0.4610;`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}