re = /(?:[\d]{2,3}?(?::IF))?[\s,&]+(?:with)?|(\S+)/m
str = '01:IF rd.h && dq.L && o.LL && v.L THEN la.VHB , av.VHR with 0.4610;'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result