#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:[\d]{2,3}?(?::IF))?[\s,&]+(?:with)?|(\S+)"
Local $sString = "01:IF rd.h && dq.L && o.LL && v.L THEN la.VHB , av.VHR with 0.4610;"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)