#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^ *(?P<header1>(?:[\u0391-\u03A1\u03A3-\u03A9]+\b(?!\.)(?: +[\u0391-\u03A1\u03A3-\u03A9]+)*\b)?)(?: +(?P<header2>.*))?"
Local $sString = "ΓΙΑΝΝΙΤΣΩΝ" & @CRLF & _
"ΓΙΑΝΝΙΤΣΩΝ Γεώργιος" & @CRLF & _
"ΕΛΕΥΘΕΡΙΟ Άγιος Γεώργιος"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")