$re = '/^ *(?P<header1>(?:[\u0391-\u03A1\u03A3-\u03A9]+\b(?!\.)(?: +[\u0391-\u03A1\u03A3-\u03A9]+)*\b)?)(?: +(?P<header2>.*))?/m';
$str = 'ΓΙΑΝΝΙΤΣΩΝ
ΓΙΑΝΝΙΤΣΩΝ Γεώργιος
ΕΛΕΥΘΕΡΙΟ Άγιος Γεώργιος';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);