using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^ *(?P<header1>(?:[\u0391-\u03A1\u03A3-\u03A9]+\b(?!\.)(?: +[\u0391-\u03A1\u03A3-\u03A9]+)*\b)?)(?: +(?P<header2>.*))?";
string input = @"ΓΙΑΝΝΙΤΣΩΝ
ΓΙΑΝΝΙΤΣΩΝ Γεώργιος
ΕΛΕΥΘΕΡΙΟ Άγιος Γεώργιος";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}