use strict;
my $str = 'ΓΙΑΝΝΙΤΣΩΝ
ΓΙΑΝΝΙΤΣΩΝ Γεώργιος
ΕΛΕΥΘΕΡΙΟ Άγιος Γεώργιος';
my $regex = qr/^ *(?P<header1>(?:[\u0391-\u03A1\u03A3-\u03A9]+\b(?!\.)(?: +[\u0391-\u03A1\u03A3-\u03A9]+)*\b)?)(?: +(?P<header2>.*))?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}