import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[^A-Z\\n]*[A-Z])(?=[^0-9\\n]*[0-9])[0-9 A-Z]*$";
final String string = "3 T1F ROHITE01WMILWI16\n"
+ "3 T1F ROHITHE01WMILwI16\n"
+ "3 T1F ROHITHE01WMIL.I16\n"
+ "1234\n"
+ "aaaa\n"
+ "T1F ROHITHE01WMILWI16";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}