const regex = /^(?=[^A-Z\n]*[A-Z])(?=[^0-9\n]*[0-9])[0-9 A-Z]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=[^A-Z\\n]*[A-Z])(?=[^0-9\\n]*[0-9])[0-9 A-Z]*$', 'gm')
const str = `3 T1F ROHITE01WMILWI16
3 T1F ROHITHE01WMILwI16
3 T1F ROHITHE01WMIL.I16
1234
aaaa
T1F ROHITHE01WMILWI16`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}