re = /^(?=[^A-Z\n]*[A-Z])(?=[^0-9\n]*[0-9])[0-9 A-Z]*$/m
str = '3 T1F ROHITE01WMILWI16
3 T1F ROHITHE01WMILwI16
3 T1F ROHITHE01WMIL.I16
1234
aaaa
T1F ROHITHE01WMILWI16'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end