use strict;
my $str = '3 T1F ROHITE01WMILWI16
3 T1F ROHITHE01WMILwI16
3 T1F ROHITHE01WMIL.I16
1234
aaaa
T1F ROHITHE01WMILWI16';
my $regex = qr/^(?=[^A-Z\n]*[A-Z])(?=[^0-9\n]*[0-9])[0-9 A-Z]*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}