#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)\(\_IF\_\(\%([a-zA-Z0-9_]+)\=([a-zA-Z0-9_]+)\)\{\s+(.*?)\s+(\}\)+)"
Local $sString = "<div class="right-side w-37">" & @CRLF & _
" (_IF_(%verified=1){" & @CRLF & _
" (_IF_(%post_on_profile=1){" & @CRLF & _
" what is going on!!" & @CRLF & _
" })" & @CRLF & _
" })" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")