import re
regex = re.compile(r"\(\_IF\_\(\%([a-zA-Z0-9_]+)\=([a-zA-Z0-9_]+)\)\{\s+(.*?)\s+(\}\)+)", flags=re.DOTALL)
test_str = ("<div class=\"right-side w-37\">\n"
" (_IF_(%verified=1){\n"
" (_IF_(%post_on_profile=1){\n"
" what is going on!!\n"
" })\n"
" })\n"
"</div>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")