const regex = /\(\_IF\_\(\%([a-zA-Z0-9_]+)\=([a-zA-Z0-9_]+)\)\{\s+(.*?)\s+(\}\)+)/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(\\_IF\\_\\(\\%([a-zA-Z0-9_]+)\\=([a-zA-Z0-9_]+)\\)\\{\\s+(.*?)\\s+(\\}\\)+)', 's')
const str = `<div class="right-side w-37">
(_IF_(%verified=1){
(_IF_(%post_on_profile=1){
what is going on!!
})
})
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}