import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(\\_IF\\_\\(\\%([a-zA-Z0-9_]+)\\=([a-zA-Z0-9_]+)\\)\\{\\s+(.*?)\\s+(\\}\\)+)";
final String string = "<div class=\"right-side w-37\">\n"
+ " (_IF_(%verified=1){\n"
+ " (_IF_(%post_on_profile=1){\n"
+ " what is going on!!\n"
+ " })\n"
+ " })\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}