#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*window\.).*\b(console\.log|alert)\b.*$"
Local $sString = "somecode console.log()" & @CRLF & _
"" & @CRLF & _
"somecode alert()" & @CRLF & _
"" & @CRLF & _
"somecode window.alert()" & @CRLF & _
"" & @CRLF & _
"somecode console.log() window.alert()" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"somecode alert() somecode" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")