re = /^(?!.*window\.).*\b(console\.log|alert)\b.*$/m
str = 'somecode console.log()
somecode alert()
somecode window.alert()
somecode console.log() window.alert()
somecode alert() somecode
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end