$re = '/^(?!.*window\.).*\b(console\.log|alert)\b.*$/m';
$str = 'somecode console.log()
somecode alert()
somecode window.alert()
somecode console.log() window.alert()
somecode alert() somecode
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);