using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*window\.).*\b(console\.log|alert)\b.*$";
string input = @"somecode console.log()
somecode alert()
somecode window.alert()
somecode console.log() window.alert()
somecode alert() somecode
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}