using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""
^(?:[^""\n]*""[^""\n]*"")*[^""\n]*""[\w\s]*([^""\w\s\n])[\w\s*]*""
""";
string input = @"
""sele%ct""
""select"",""Wow""
""select"" ""wow"" ""w&ow""
this has ""some text within quotes""
This has ""one quote"" & ""another quote""
This has ""this & that"" in quotes
This has ""this & that"" as well as ""something & another thing""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}