$re = '/^(?:[^"\n]*"[^"\n]*")*[^"\n]*"[\w\s]*([^"\w\s\n])[\w\s*]*"/m';
$str = '
"sele%ct"
"select","Wow"
"select" "wow" "w&ow"
this has "some text within quotes"
This has "one quote" & "another quote"
This has "this & that" in quotes
This has "this & that" as well as "something & another thing"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);