import re
regex = re.compile(r"^(?:[^\"\n]*\"[^\"\n]*\")*[^\"\n]*\"[\w\s]*([^\"\w\s\n])[\w\s*]*\"", flags=re.MULTILINE)
test_str = ("\n"
"\"sele%ct\"\n"
"\"select\",\"Wow\"\n"
"\"select\" \"wow\" \"w&ow\"\n\n"
"this has \"some text within quotes\"\n\n"
"This has \"one quote\" & \"another quote\"\n\n"
"This has \"this & that\" in quotes\n\n"
"This has \"this & that\" as well as \"something & another thing\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")