const regex = new RegExp('^(?:[^"\\n]*"[^"\\n]*")*[^"\\n]*"[\\w\\s]*([^"\\w\\s\\n])[\\w\\s*]*"', 'gm')
const str = `
"sele%ct"
"select","Wow"
"select" "wow" "w&ow"
this has "some text within quotes"
This has "one quote" & "another quote"
This has "this & that" in quotes
This has "this & that" as well as "something & another thing"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}