#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?i)\b(Maz( )?Kana(a)?ta|Han( )?Solo|Har(r)?ison( )?Ford|Leia|Carrie( )?Fisher|Skywalker|Hamill|Chewbacca|Chewie|Wookie|Mayhew|Kylo|Adam( )?Driver|Daisy( )?Ridley|Boyega|Abrams|J(\.)?( )?J(\.)?( )?(A)?(\.)?( )?|Hux|Domhnall|Gleeson|Phasma|Gwendoline|Vader|Darth|Snoke|R2(\-)?D2|C3PO|Lor( )?San|Tekka|Sydow|BB(\-)?8|Dameron|Oscar( )?Isa(a)?c|Star( )?War(s)?|Force( )?Awakens|Light( )?saber|Jedi|Storm( )?trooper|Millennium( )?Falcon)"
Local $sString = "* Maz Kanata" & @CRLF & _
"* Han Solo, Harrison Ford+" & @CRLF & _
"* Leia, Carrie Fisher+" & @CRLF & _
"* Skywalker, Hamill+" & @CRLF & _
"* Chewbacca, Chewie, Wookie(e), Mayhew+" & @CRLF & _
"* Kylo, Adam Driver+" & @CRLF & _
"* Daisy Ridley+" & @CRLF & _
"* Boyega+" & @CRLF & _
"* Abrams+, JJA+, J.J.A.+, J. J. A.+" & @CRLF & _
"* (General) Hux, Domhnall+, Gleeson+" & @CRLF & _
"* (Captain) Phasma, Gwendoline (Christie)+" & @CRLF & _
"* Vader, Darth - sorry, [@darth][]" & @CRLF & _
"* Snoke" & @CRLF & _
"* R2-D2" & @CRLF & _
"* C3PO" & @CRLF & _
"* Lor San, Tekka, (Max von) Sydow+" & @CRLF & _
"* BB-8" & @CRLF & _
"* (Poe) Dameron, Oscar Isaac+" & @CRLF & _
"" & @CRLF & _
"* * * *" & @CRLF & _
"" & @CRLF & _
"* Star Wars, Force Awakens" & @CRLF & _
"* Lightsaber" & @CRLF & _
"* Jedi" & @CRLF & _
"* Stormtrooper" & @CRLF & _
"* Millennium Falcon" & @CRLF & _
"" & @CRLF & _
"* * * *" & @CRLF & _
"" & @CRLF & _
"`+` Refers to a filter based on the actor/director’s real name. You may not want to include this, if you want to follow the person—while risking the spoiler. You may have wondered why Lupita Nyong’o is not on the list. Go figure." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[@darth]: https://twitter.com/darth"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")