use strict;
my $str = '* Maz Kanata
* Han Solo, Harrison Ford+
* Leia, Carrie Fisher+
* Skywalker, Hamill+
* Chewbacca, Chewie, Wookie(e), Mayhew+
* Kylo, Adam Driver+
* Daisy Ridley+
* Boyega+
* Abrams+, JJA+, J.J.A.+, J. J. A.+
* (General) Hux, Domhnall+, Gleeson+
* (Captain) Phasma, Gwendoline (Christie)+
* Vader, Darth - sorry, [@darth][]
* Snoke
* R2-D2
* C3PO
* Lor San, Tekka, (Max von) Sydow+
* BB-8
* (Poe) Dameron, Oscar Isaac+
* * * *
* Star Wars, Force Awakens
* Lightsaber
* Jedi
* Stormtrooper
* Millennium Falcon
* * * *
`+` Refers to a filter based on the actor/director’s real name. You may not want to include this, if you want to follow the person—while risking the spoiler. You may have wondered why Lupita Nyong’o is not on the list. Go figure.
[@darth]: https://twitter.com/darth';
my $regex = qr/(?i)\b(Maz( )?Kana(a)?ta|Han( )?Solo|Har(r)?ison( )?Ford|Leia|Carrie( )?Fisher|Skywalker|Hamill|Chewbacca|Chewie|Wookie|Mayhew|Kylo|Adam( )?Driver|Daisy( )?Ridley|Boyega|Abrams|J(\.)?( )?J(\.)?( )?(A)?(\.)?( )?|Hux|Domhnall|Gleeson|Phasma|Gwendoline|Vader|Darth|Snoke|R2(\-)?D2|C3PO|Lor( )?San|Tekka|Sydow|BB(\-)?8|Dameron|Oscar( )?Isa(a)?c|Star( )?War(s)?|Force( )?Awakens|Light( )?saber|Jedi|Storm( )?trooper|Millennium( )?Falcon)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}