// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?i)\b(Maz( )?Kana(a)?ta|Han( )?Solo|Har(r)?ison( )?Ford|Leia|Carrie( )?Fisher|Skywalker|Hamill|Chewbacca|Chewie|Wookie|Mayhew|Kylo|Adam( )?Driver|Daisy( )?Ridley|Boyega|Abrams|J(\.)?( )?J(\.)?( )?(A)?(\.)?( )?|Hux|Domhnall|Gleeson|Phasma|Gwendoline|Vader|Darth|Snoke|R2(\-)?D2|C3PO|Lor( )?San|Tekka|Sydow|BB(\-)?8|Dameron|Oscar( )?Isa(a)?c|Star( )?War(s)?|Force( )?Awakens|Light( )?saber|Jedi|Storm( )?trooper|Millennium( )?Falcon)").unwrap();
let string = "* Maz Kanata
* Han Solo, Harrison Ford+
* Leia, Carrie Fisher+
* Skywalker, Hamill+
* Chewbacca, Chewie, Wookie(e), Mayhew+
* Kylo, Adam Driver+
* Daisy Ridley+
* Boyega+
* Abrams+, JJA+, J.J.A.+, J. J. A.+
* (General) Hux, Domhnall+, Gleeson+
* (Captain) Phasma, Gwendoline (Christie)+
* Vader, Darth - sorry, [@darth][]
* Snoke
* R2-D2
* C3PO
* Lor San, Tekka, (Max von) Sydow+
* BB-8
* (Poe) Dameron, Oscar Isaac+
* * * *
* Star Wars, Force Awakens
* Lightsaber
* Jedi
* Stormtrooper
* Millennium Falcon
* * * *
`+` Refers to a filter based on the actor/director’s real name. You may not want to include this, if you want to follow the person—while risking the spoiler. You may have wondered why Lupita Nyong’o is not on the list. Go figure.
[@darth]: https://twitter.com/darth";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}