# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)\b(Maz( )?Kana(a)?ta|Han( )?Solo|Har(r)?ison( )?Ford|Leia|Carrie( )?Fisher|Skywalker|Hamill|Chewbacca|Chewie|Wookie|Mayhew|Kylo|Adam( )?Driver|Daisy( )?Ridley|Boyega|Abrams|J(\.)?( )?J(\.)?( )?(A)?(\.)?( )?|Hux|Domhnall|Gleeson|Phasma|Gwendoline|Vader|Darth|Snoke|R2(\-)?D2|C3PO|Lor( )?San|Tekka|Sydow|BB(\-)?8|Dameron|Oscar( )?Isa(a)?c|Star( )?War(s)?|Force( )?Awakens|Light( )?saber|Jedi|Storm( )?trooper|Millennium( )?Falcon)"
test_str = ("* Maz Kanata\n"
"* Han Solo, Harrison Ford+\n"
"* Leia, Carrie Fisher+\n"
"* Skywalker, Hamill+\n"
"* Chewbacca, Chewie, Wookie(e), Mayhew+\n"
"* Kylo, Adam Driver+\n"
"* Daisy Ridley+\n"
"* Boyega+\n"
"* Abrams+, JJA+, J.J.A.+, J. J. A.+\n"
"* (General) Hux, Domhnall+, Gleeson+\n"
"* (Captain) Phasma, Gwendoline (Christie)+\n"
"* Vader, Darth - sorry, [@darth][]\n"
"* Snoke\n"
"* R2-D2\n"
"* C3PO\n"
"* Lor San, Tekka, (Max von) Sydow+\n"
"* BB-8\n"
"* (Poe) Dameron, Oscar Isaac+\n\n"
"* * * *\n\n"
"* Star Wars, Force Awakens\n"
"* Lightsaber\n"
"* Jedi\n"
"* Stormtrooper\n"
"* Millennium Falcon\n\n"
"* * * *\n\n"
"`+` Refers to a filter based on the actor/director’s real name. You may not want to include this, if you want to follow the person—while risking the spoiler. You may have wondered why Lupita Nyong’o is not on the list. Go figure.\n\n\n"
"[@darth]: https://twitter.com/darth")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.