using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([d]?\()?[QqTt;.Oo><^*~e'ಠov$\-+!?`]
([o.^_m-]+|╭╮)
[QqTt;.Oo><^*~e'ಠov$\-+!?`](\)[b]?)?|
([IlXxDd)(<\[#LCcOoq\/\\*][-]?['^""]?
[;:8B|][<]?|
[>]?[;:8B|Xx]['^""]?[-]?[7IlXxD)(>\]3#|LCcOoPp\/\\*])|
[.\\\/]+[om][.\\\/]+|(¯\\*_\(ツ\)_\/¯)|
\( ͡° ͜ʖ ͡°\)|
[<>]?[}\])]:\(?[:o]\)|\([:o]\):[(\[{][<>]?|
@--}--|<[\/\\]?3|
\([╯」][°゜][□ロ][°゜][)\)][╯」](︵\ ┻━┻)?";
string input = @"ಠmಠ";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}