$re = '/([d]?\()?[QqTt;.Oo><^*~e\'ಠov$\-+!?`]
([o.^_m-]+|╭╮)
[QqTt;.Oo><^*~e\'ಠov$\-+!?`](\)[b]?)?|
([IlXxDd)(<\[#LCcOoq\/\\\\*][-]?[\'^"]?
[;:8B|][<]?|
[>]?[;:8B|Xx][\'^"]?[-]?[7IlXxD)(>\]3#|LCcOoPp\/\\\\*])|
[.\\\\\/]+[om][.\\\\\/]+|(¯\\\\*_\(ツ\)_\/¯)|
\( ͡° ͜ʖ ͡°\)|
[<>]?[}\])]:\(?[:o]\)|\([:o]\):[(\[{][<>]?|
@--}--|<[\/\\\\]?3|
\([╯」][°゜][□ロ][°゜][)\)][╯」](︵\ ┻━┻)?/x';
$str = 'ಠmಠ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);