import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([d]?\\()?[QqTt;.Oo><^*~e'ಠov$\\-+!?`]\n"
+ "([o.^_m-]+|╭╮)\n"
+ "[QqTt;.Oo><^*~e'ಠov$\\-+!?`](\\)[b]?)?|\n"
+ "([IlXxDd)(<\\[#LCcOoq\\/\\\\*][-]?['^\"]?\n"
+ "[;:8B|][<]?|\n"
+ "[>]?[;:8B|Xx]['^\"]?[-]?[7IlXxD)(>\\]3#|LCcOoPp\\/\\\\*])|\n"
+ "[.\\\\\\/]+[om][.\\\\\\/]+|(¯\\\\*_\\(ツ\\)_\\/¯)|\n"
+ "\\( ͡° ͜ʖ ͡°\\)|\n"
+ "[<>]?[\\}\\])]:\\(?[:o]\\)|\\([:o]\\):[(\\[\\{][<>]?|\n"
+ "@--\\}--|<[\\/\\\\]?3|\n"
+ "\\([╯」][°゜][□ロ][°゜][)\\)][╯」](︵\\ ┻━┻)?";
final String string = "ಠmಠ";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}