package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[;.Oo><^*~e'ಠov$\-+!?`][o.^_-]+[;!?\-`+$.Oo><^*~e'oಠv]|([Dd)(<\[#LCcOo/\\*][-]?['^"]?[;:8B|][<]?|[>]?[;:8B|]['"^]?[-]?[D)(>\]3#|LCcOoPp/\\*])|[.\\\/]+[om][.\\\/]+|(¯\\*_\(ツ\)_\/¯)|\( ͡° ͜ʖ ͡°\)|[<>]?[}\])]:\(?[:o]\)|\([:o]\):[(\[{][<>]?|@--}--`)
var str = `@--}--`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}