const regex = /[;.Oo><^*~e'ಠov$\-+!?`][o.^_-]+[;!?\-`+$.Oo><^*~e'oಠv]|([Dd)(<\[#LCcOo/\\*][-]?['^"]?[;:8B|][<]?|[>]?[;:8B|]['"^]?[-]?[D)(>\]3#|LCcOoPp/\\*])|[.\\\/]+[om][.\\\/]+|(¯\\*_\(ツ\)_\/¯)|\( ͡° ͜ʖ ͡°\)|[<>]?[}\])]:\(?[:o]\)|\([:o]\):[(\[{][<>]?|@--}--/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[;.Oo><^*~e\'ಠov$\\-+!?`][o.^_-]+[;!?\\-`+$.Oo><^*~e\'oಠv]|([Dd)(<\\[#LCcOo\/\\\\*][-]?[\'^"]?[;:8B|][<]?|[>]?[;:8B|][\'"^]?[-]?[D)(>\\]3#|LCcOoPp\/\\\\*])|[.\\\\\\\/]+[om][.\\\\\\\/]+|(¯\\\\*_\\(ツ\\)_\\\/¯)|\\( ͡° ͜ʖ ͡°\\)|[<>]?[}\\])]:\\(?[:o]\\)|\\([:o]\\):[(\\[{][<>]?|@--}--', '')
const str = `@--}--`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}