use strict;
my $str = '@--}--';
my $regex = qr/[;.Oo><^*~e'ಠov$\-+!?`][o.^_-]+[;!?\-`+$.Oo><^*~e'oಠv]|([Dd)(<\[#LCcOo/\\*][-]?['^"]?[;:8B|][<]?|[>]?[;:8B|]['"^]?[-]?[D)(>\]3#|LCcOoPp/\\*])|[.\\\/]+[om][.\\\/]+|(¯\\*_\(ツ\)_\/¯)|\( ͡° ͜ʖ ͡°\)|[<>]?[}\])]:\(?[:o]\)|\([:o]\):[(\[{][<>]?|@--}--/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}