import Foundation
let pattern = ##"[;.Oo><^*~e'ಠov$\-+!?`][o.^_-]+[;!?\-`+$.Oo><^*~e'oಠv]|([Dd)(<\[#LCcOo/\\*][-]?['^"]?[;:8B|][<]?|[>]?[;:8B|]['"^]?[-]?[D)(>\]3#|LCcOoPp/\\*])|[.\\\/]+[om][.\\\/]+|(¯\\*_\(ツ\)_\/¯)|\( ͡° ͜ʖ ͡°\)|[<>]?[}\])]:\(?[:o]\)|\([:o]\):[(\[{][<>]?|@--}--"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"@--}--"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}