using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"RewriteRule ^([d-u]+)-(eu|us)\/faq(?:%25)([\w]+)$ $1-$2\/faq#$4 [R=301,L]";
string input = @"http://broadbandforum.co/offer.php?link=http%3A%2F%2Fwww.youtube.com%2Fattribution_link%3Fa%3DfF1CWYwxCQ4%26u%3D%2Fwatch%253Fv%253DqYr8opTPSaQ%2526feature%253Dem-uploademail";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}