// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"RewriteRule ^([d-u]+)-(eu|us)\/faq(?:%25)([\w]+)$ $1-$2\/faq#$4 [R=301,L]").unwrap();
let string = "http://broadbandforum.co/offer.php?link=http%3A%2F%2Fwww.youtube.com%2Fattribution_link%3Fa%3DfF1CWYwxCQ4%26u%3D%2Fwatch%253Fv%253DqYr8opTPSaQ%2526feature%253Dem-uploademail";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}