package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`RewriteRule ^([d-u]+)-(eu|us)\/faq(?:%25)([\w]+)$ $1-$2\/faq#$4 [R=301,L]`)
var str = `http://broadbandforum.co/offer.php?link=http%3A%2F%2Fwww.youtube.com%2Fattribution_link%3Fa%3DfF1CWYwxCQ4%26u%3D%2Fwatch%253Fv%253DqYr8opTPSaQ%2526feature%253Dem-uploademail`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}