$re = '/RewriteRule ^([d-u]+)-(eu|us)\/faq(?:%25)([\w]+)$ $1-$2\/faq#$4 [R=301,L]/';
$str = 'http://broadbandforum.co/offer.php?link=http%3A%2F%2Fwww.youtube.com%2Fattribution_link%3Fa%3DfF1CWYwxCQ4%26u%3D%2Fwatch%253Fv%253DqYr8opTPSaQ%2526feature%253Dem-uploademail';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);