using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*([\w ]+):\s*(\[((?>[^[\]]+|(?2))*)\])";
string substitution = @"Field: \1 Value: \3\n";
string input = @"BotInfo[-]: Source IP:[10.1.1.100] Target Host:[CentOS70-1] Target OS:[CentOS 7.0] Description:[HTTP Connection Request] Details:[10.1.1.101 - - [28/May /2013:12:24:08 +0000] ""GET /math/html.mli HTTP/1.0"" 404 3567 ""-"" ""-"" ] Phase: [Access] Service:[WEB]
Target Os:[Centos]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}