import Foundation
let pattern = #"\s*([\w ]+):\s*(\[((?>[^[\]]+|(?2))*)\])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
BotInfo[-]: Source IP:[10.1.1.100] Target Host:[CentOS70-1] Target OS:[CentOS 7.0] Description:[HTTP Connection Request] Details:[10.1.1.101 - - [28/May /2013:12:24:08 +0000] "GET /math/html.mli HTTP/1.0" 404 3567 "-" "-" ] Phase: [Access] Service:[WEB]
Target Os:[Centos]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Field: \1 Value: \3\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)