import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*([\\w ]+):\\s*(\\[((?>[^[\\]]+|(?2))*)\\])";
final String string = "BotInfo[-]: Source IP:[10.1.1.100] Target Host:[CentOS70-1] Target OS:[CentOS 7.0] Description:[HTTP Connection Request] Details:[10.1.1.101 - - [28/May /2013:12:24:08 +0000] \"GET /math/html.mli HTTP/1.0\" 404 3567 \"-\" \"-\" ] Phase: [Access] Service:[WEB]\n\n"
+ "Target Os:[Centos]";
final String subst = "Field: \\1 Value: \\3\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}