using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*)([\w_-]{11})\.(mp4|mkv|flv)$";
string input = @"ATI Stream OpenCLâ„¢ Technical Overview [Part 1] - What is OpenCLâ„¢-ecYIsu83c0I.mkv
ATI Stream OpenCLâ„¢ Technical Overview [Part 2] - What is OpenCLâ„¢ (Continued)-PxPs9yKs5P8.mkv
ATI Stream OpenCLâ„¢ Technical Overview [Part 3a] - Resource Setup-EbXf7MRXlpE.mkv
ATI Stream OpenCLâ„¢ Technical Overview [Part 3b] - Resource Setup-uaevrJbksA0.mkv
ATI Stream OpenCLâ„¢ Technical Overview [Part 4a] - Kernel Execution-IBTH2tDLqXU.mkv
ATI Stream OpenCLâ„¢ Technical Overview [Part 4b] - Kernel Execution-SzymylQaA5w.mkv
ATI Stream OpenCLâ„¢ Technical Overview [Part 5a] - Programming with OpenCLâ„¢ C-KFAkUsn4YPg.mkv
ATI Stream OpenCLâ„¢ Technical Overview [Part 5b] - Programming with OpenCLâ„¢ C-Jt4iTDvGdNE.mkv
ATI Stream Technology Driving the Future of HPC--LXAa8wm23E.mkv";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}