re = /^(.*)([\w_-]{11})\.(mp4|mkv|flv)$/m
str = 'ATI Stream OpenCLâ„¢ Technical Overview [Part 1] - What is OpenCLâ„¢-ecYIsu83c0I.mkv
ATI Stream OpenCLâ„¢ Technical Overview [Part 2] - What is OpenCLâ„¢ (Continued)-PxPs9yKs5P8.mkv
ATI Stream OpenCLâ„¢ Technical Overview [Part 3a] - Resource Setup-EbXf7MRXlpE.mkv
ATI Stream OpenCLâ„¢ Technical Overview [Part 3b] - Resource Setup-uaevrJbksA0.mkv
ATI Stream OpenCLâ„¢ Technical Overview [Part 4a] - Kernel Execution-IBTH2tDLqXU.mkv
ATI Stream OpenCLâ„¢ Technical Overview [Part 4b] - Kernel Execution-SzymylQaA5w.mkv
ATI Stream OpenCLâ„¢ Technical Overview [Part 5a] - Programming with OpenCLâ„¢ C-KFAkUsn4YPg.mkv
ATI Stream OpenCLâ„¢ Technical Overview [Part 5b] - Programming with OpenCLâ„¢ C-Jt4iTDvGdNE.mkv
ATI Stream Technology Driving the Future of HPC--LXAa8wm23E.mkv'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end